Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

  • Página:
  • 1

TÓPICO: Problema ao inserir novo idioma no iGO Primo - Android

Problema ao inserir novo idioma no iGO Primo - Android 25 Set 2012 19:56 #173625

Galera, achei que meu iGO não estava aceitando instalar a locução da Gabriela com TTS, mas o problema é bem maior.
Cansado de tentar esse com TTS, sem obter exito, resolvi instalar uma voz comum, sem TTS, e baixei o arquivo VOICE da Ana Maria várias vezes, e todos apresentavam um aviso no momento de inicialização do aplicativo, e onde configura a narração, não aparece a nova voz instalada.
Socorro galera, não aguento mais ouvir os comandos em Português de PORTUGAL.
Obrigado.
  • Henrique B
  • Iniciante
  • Henrique B's Avatar
  • OFFLINE
  • Postagens: 7
  • Registro em: 21/03/2012
    Ult. Visita: 08/10/2015
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 26 Set 2012 11:50 #173719

Caro Henrique B

Inclua no seu sys.txt:

[sound]
csv_voice_enabled=1

Avise depois se funcionou.
Abs.
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: Henrique B

Re: Problema ao inserir novo idioma no iGO Primo - Android 26 Set 2012 21:48 #173828

PPP

Na mosca, funcionou perfeitamente na voz da Ana Maria.
Agora, tentei instalar novamente o pacote da Gabriela com TTS, mas infelizmente não funcionou.
Mas só de tirar aquela voz de Portugal, já agradeço muito à você.

Abs
Henrique
  • Henrique B
  • Iniciante
  • Henrique B's Avatar
  • OFFLINE
  • Postagens: 7
  • Registro em: 21/03/2012
    Ult. Visita: 08/10/2015
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 27 Set 2012 09:18 #173854

Henrique

Para que uma voz TTS funcione perfeitamente, é necessário que os vários arquivos contidos no pacote sejam colocados nas devidas pastas.
Se faltar um arquivo que seja a coisa não funciona.
Um indicativo de que está tudo OK é, no momento em que se seleciona uma voz, ouve-se, depois de alguns segundos, o dono da voz falando alguma coisa, tipo 'dirija com cuidado'.

Se vc selecionou a voz, esperou algum tempo, e nada aconteceu, nenhum som foi ouvido, nem adianta clicar em VOLTAR, pois a voz antiga vai continuar lá.

Abs
  • luizcarlosrio
  • Moderador
  • luizcarlosrio's Avatar
  • OFFLINE
  • Postagens: 2016
  • Agradecimentos: 926
  • Registro em: 04/07/2011
    Ult. Visita: 30/11/2016
Por favor, não me envie msg privada pedindo ajuda, pergunte aqui no fórum. Minha resposta lhe foi útil
e você faz questão de agradecer? Não escreva uma msg agradecendo, apenas aperte o botão. :)
Última Edição: 27 Set 2012 09:19 por luizcarlosrio.
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 27 Set 2012 12:28 #173900

Luiz

Realmente, coloquei todas as pastas nos devidos lugares, e adicionei o texto na arquivo System.ini, mas quando ligo o gps, nem aparece a voz em TTS para selecionar.

Obrigado.
Henrique
  • Henrique B
  • Iniciante
  • Henrique B's Avatar
  • OFFLINE
  • Postagens: 7
  • Registro em: 21/03/2012
    Ult. Visita: 08/10/2015
Última Edição: 27 Set 2012 12:29 por Henrique B.
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 27 Set 2012 12:38 #173901

Henrique B

Tente inserir no sys.txt o seguinte parágrafo (ou somente as linhas, se o parágrafo já existir):

[tts]
priority="NORMAL"
ttspro_da_voice_enabled=1
use_tts_lang=1

Depois diga se mudou alguma coisa
  • luizcarlosrio
  • Moderador
  • luizcarlosrio's Avatar
  • OFFLINE
  • Postagens: 2016
  • Agradecimentos: 926
  • Registro em: 04/07/2011
    Ult. Visita: 30/11/2016
Por favor, não me envie msg privada pedindo ajuda, pergunte aqui no fórum. Minha resposta lhe foi útil
e você faz questão de agradecer? Não escreva uma msg agradecendo, apenas aperte o botão. :)
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 27 Set 2012 21:01 #173989

Luiz

Infelizmente, não funcionou.

Eu tinha feito assim:
*Inseri esses arquivos na pasta iGO: "TTS_LOQ" (pasta) , "LOQMSX.DLL" , "LoqPortuguese6.5.dll", "LoqTTS6.dll" , "LoqTTS6_util.dll"
*Inseri esse arquivo na pasta Content/ Voice: "Voice_TTS-loq-por-bra-f1.zip"
*Inseri o seguinte paragrafo no arquivo Sys.txt:
[tts]
announce_exit_directions=3
always_say_road_names=3
announce_street_name=1
skip_exit_numbers=1

Então vi sua dica, e inseri essas linhas no final do paragrafo e ficou assim:
[tts]
announce_exit_directions=3
always_say_road_names=3
announce_street_name=1
skip_exit_numbers=1
priority="NORMAL"
ttspro_da_voice_enabled=1
use_tts_lang=1

Não funcionou, então apaguei as linhas que eu tinha inserido antes, e ficou assim:
[tts]
priority="NORMAL"
ttspro_da_voice_enabled=1
use_tts_lang=1

Continuou não funcionando, a opção de selecionar o arquivo da Gabriela no aparelho não aparece.
Esse paragrafo pode ser inserido em qualquer ponto do arquivo Sys.txt?
Só pra contar aqui, meu aparelho é um LG Optimus P698 com Android 2.3

Obrigado
Henrique
  • Henrique B
  • Iniciante
  • Henrique B's Avatar
  • OFFLINE
  • Postagens: 7
  • Registro em: 21/03/2012
    Ult. Visita: 08/10/2015
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 27 Set 2012 23:13 #174009

Henrique B

Voz TTS no Android é meio enjoado mesmo...

Na verdade quem controla a emissão dos comandos de voz é a "engine" do proprio android.

Ainda temos uma limitação: A lingua que vc escolhe dentro do iGo tem que ser a mesma lingua da interface do Android.
Por exemplo: Para o iGo falar em portugues o seu telefone/tablet tem que estar em portugues além disso no sistema tem que existir e estar ativada uma voz TTS em portugues..
Outra coisa: Não adianta nada voce escolher dentro do iGo a voz da Gabriela ou da Fernanda... O que o iGo falara é a voz da pessoa que está instalada no sistema... O fato de voce escolher uma voz dentro do iGo apenas "liga" a voz TTS.
Mais um exemplo: Se vc selecionar no ANDROID a voz do Fabio(masculina) e dentro do iGO a voz da Gabriela(feminina) você receberá as instruções do GPS pela voz do Fabio...

Tente este processo abaixo para que o iGO fale portugues do Brasil (não esqueça antes o back-up):

1)Retire da pasta iGo TODAS as dlls e as pastas TTS_Loq e também nuance.

2)Coloque o android com a interface em portugues do brasil

3)instale NO ANDROID uma voz TTS portugues (eu uso SVOX com a voz da Luciana). Teste no android se a voz TTS está funcionando pois só assim que aparecerá dentro do iGo a opção para selecionar uma voz tts.

4)pegue qualquer voz nuance em portugues BR de dentro do igo (não interessa sexo nem nome pois a voz que vc vai ouvir é a da Luciana)

5)Abra o arquivo dessa voz com o winrar e edite o arquivo info.ini

6)retire desse arquivo os comandos: (delete as linhas)
tts_engine="nuance"
phoneme_lang="POR"
tts_srate="22050"

7)Salve o arquivo.

8)Apague o arquivo Brazil.ph de dentro da pasta \content\phoneme

Agora é só selecionar dentro do iGo esta voz que vc editou.

Aproveite.

Abs.
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
Última Edição: 28 Set 2012 00:13 por PPP.
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 29 Set 2012 16:38 #174252

PPP

To tentando inserir isso aqui, mas infelizmente é bem difícil.
Você disse que o GPS "fala" com o arquivo do aparelho, e não do programa, mas no meu isso não ocorre; se eu selecionar alguma voz dentro do iGO, o GPS falará a voz que eu escolhi, mas ignorando isso, tentei fazer tudo como você disse, porem alguns pontos não foi possível realizar:
PPP escreveu:
1)Retire da pasta iGo TODAS as dlls e as pastas TTS_Loq e também nuance.
Antes de tudo, o que é "nuance"? Desculpe a pergunta besta, mas como eu disse, sou muito leigo quando se fala de GPS.
PPP escreveu:
2)Coloque o android com a interface em português do brasil

3)instale NO ANDROID uma voz TTS português (eu uso SVOX com a voz da Luciana). Teste no android se a voz TTS está funcionando pois só assim que aparecerá dentro do iGo a opção para selecionar uma voz tts.
OK
PPP escreveu:
4)pegue qualquer voz nuance em portugues BR de dentro do igo (não interessa sexo nem nome pois a voz que vc vai ouvir é a da Luciana)
Esse arquivo de voz tem que ser com TTS (Gabriela) ou comum(Ana Maria)?
É que não encontrei essas linhas dentro do "info.ini" nos arquivos de voz
PPP escreveu:
8)Apague o arquivo Brazil.ph de dentro da pasta \content\phoneme
Dentro da pasta "Content" não tem essa outra chamada "Phoneme", e os únicos arquivos nomeados "Brazil" têm extensão ".poi" e ".fbl"

Essa pasta do meu iGO tá muito esquisita, tá tudo diferente.
Vou ver se acho outro pra instalar, e ver se dá certo.

Fico no aguardo de atualizações no tópico.
Obrigado.
Abs
Henrique
  • Henrique B
  • Iniciante
  • Henrique B's Avatar
  • OFFLINE
  • Postagens: 7
  • Registro em: 21/03/2012
    Ult. Visita: 08/10/2015
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 03 Out 2012 13:38 #174679

Henrique B

Vamos por partes:

Se o programa ainda está falando a voz escolhida dentro dele é sinal que ou vc está escolhendo uma voz natural (não TTS), ou vc não retirou ainda as engines do WinCE (DLLs, e pasta TTS_Loq). Uma confirmação disso vc terá quando apertar o botão "voltar" e ver que o primo não seleciona essa voz que vc escolheu. Retire os arquivos e edite o arquivo "voice". Voce verá que o primo falará com a voz do sistema.
Nuance é uma outra "engine" para TTS além da loquendo. Normalmente os arquivos nuance ficam na pasta "tts_nua_v5"
Tem que ser um arquivo TTS (pode até ser o da Gabriela mas tem que ser do tipo "lua", não pode ser CSV. Voce diferencia um do outro descompactando o arquivo e olhando na pasta "config". Os arquivos devem ser de extensão .lua e NÃO .csv). Preferencialmente use um arquivo de voz nuance.
Se vc já não tem a pasta phoneme não precisará apaga-la certo? :whistle:

Espero que funcione!!!

Abs.
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
Última Edição: 03 Out 2012 13:50 por PPP.
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 03 Out 2012 21:10 #174730

PPS

Já to ficando louco, hora que acho que vai dar certo, dá tudo errado.

Olhei esses dentro da pasta config, e tava tudo no formato .csv;
Resolvi então, baixar outro pack da Gabriela, mas ele também veio com esses arquivos em formato .csv.
Coloquei ele na pasta, e iniciei o Igo, pra ver oq acontecia, e dessa vez, apareceu a voz da Gabriela, então imaginei que estava caminhando para o bom funcionamento do sistema, mas infelizmente, ´não é a voz da LUCIANA (instalada no aparelho), e sim a da Gabriela que diz "Boa viagem ..."
Então, tentei selecioná-la, e quando volto a tela anterior, a voz da Ana Maria, continua como selecionada.
Pensei, agora é só executar os passos que você tinha dito, MAS...
Apos isso, o infeliz do Igo trava ao carregar!
Fui lá, e desfiz apenas as modificações no arquivo info.ini, e ele voltou a abrir, porém, não funciona o TTS (não é a Luciana que fala, nem fica selecionado a voz com TTS).

Peço à você, quanto a qualquer outro membro aqui do fórum, que me ajudem somente se for conveniente a vocês, não quero ser chato, passando problemas à vocês.
Esse caso tá meio sem solução, ao meu ver.

Se você conseguir me indicar onde baixar esses arquivos de voz TTS, ou o próprio iGO para Android (480x320), que você já testou, pois o que baixei, tem algumas coisas diferentes, talvez, ajude a resolver isso.

Por ex:
As linhas que você disse pra apagar:
tts_engine="nuance"
phoneme_lang="POR"
tts_srate="22050"

O que encontrei estavam assim:
tts_engine="loquendo"
phoneme_lang="POR"
tts_rate=50

Obrigado pela compreensão
Grande abraço
Henrique
  • Henrique B
  • Iniciante
  • Henrique B's Avatar
  • OFFLINE
  • Postagens: 7
  • Registro em: 21/03/2012
    Ult. Visita: 08/10/2015
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 03 Out 2012 22:42 #174764

Eu fiz a instalação hoje no meu galaxy spica / lite e estou com o mesmo problema.

Acredito que esse problema é causado pq o iGO não detecta o Svox classic como TTS Pro, no menu Sons e avisos.

Tenho instalado a última versão do Svox classic e da voz da Luciana, mas isso não resolve.
  • rds04
  • Iniciante
  • rds04's Avatar
  • OFFLINE
  • Postagens: 3
  • Registro em: 04/10/2012
    Ult. Visita: 10/10/2012
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 05 Out 2012 13:47 #175012

Senhores moderadores,

Posso postar aqui uma voz PTBR original nuance e alterada por mim para que funcione no Primo Android com SVOX?

Pergunto pois os colegas Henrique B e rds04 estão com dificuldade em produzir esse conteúdo e eu não conheço a lei de direitos autorais a ponto de saber se um arquivo alterado pode ser distribuido...

Obrigado
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: rds04, renansprado

Re: Problema ao inserir novo idioma no iGO Primo - Android 06 Out 2012 04:08 #175103

Voce pode me mandar por email :)
  • rds04
  • Iniciante
  • rds04's Avatar
  • OFFLINE
  • Postagens: 3
  • Registro em: 04/10/2012
    Ult. Visita: 10/10/2012
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 06 Out 2012 05:26 #175104

Henrique B escreveu:
PPS

Se você conseguir me indicar onde baixar esses arquivos de voz TTS, ou o próprio iGO para Android (480x320), que você já testou, pois o que baixei, tem algumas coisas diferentes, talvez, ajude a resolver isso.

Henrique

O mais atual que encontrei foi nesse site forum.mobilism.org/v...c.php?f=701&t=369365
  • rds04
  • Iniciante
  • rds04's Avatar
  • OFFLINE
  • Postagens: 3
  • Registro em: 04/10/2012
    Ult. Visita: 10/10/2012
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 19 Out 2012 02:27 #176650

Poderia enviar por email pra mim também ?
  • renansprado
  • Iniciante
  • renansprado's Avatar
  • OFFLINE
  • Postagens: 1
  • Registro em: 19/10/2012
    Ult. Visita: 07/01/2015
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 19 Out 2012 13:32 #176677

Amigo PPP poderia por gentileza me enviar esse pacote de vozes por email?
  • Dony_b
  • Iniciante
  • Dony_b's Avatar
  • OFFLINE
  • Postagens: 2
  • Registro em: 13/08/2011
    Ult. Visita: 10/11/2016
O administrador desabilitou o acesso público de escrita.

Re: Problema ao inserir novo idioma no iGO Primo - Android 05 Out 2015 14:09 #249419

ola amigos,
estou tentando instalar a voz no android lplipop num Moto G, emesmo com a voz tts escolhida em portugues do brasil, o som sai em portugues de PORTUGAL, alguem pode me ajudar ai?
obrigado
  • mafbueno
  • Usuário Prata
  • mafbueno's Avatar
  • OFFLINE
  • Postagens: 127
  • Agradecimentos: 27
  • Registro em: 01/06/2011
    Ult. Visita: 30/11/2016
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.347 seconds