Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

  • Página:
  • 1

TÓPICO: Primo 2.4 9.6.27.503057 Windows CE [Resolvido]

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 29 Mar 2016 16:58 #257107

Caros amigos e mestres do GPSPoint,


Estou tendo um problema que esta me “tirando o sono”.

Eu explico:

No final do ano passado adquiri um veículo e fiquei positivamente surpreso quando descobri que na central original dele o navegador instalado é o nosso bom e velho Primo.

Mais surpreso ainda fiquei quando ví a versão do executável. Ela era 9.6.27.503057

Até então só tinha visto essa versão para Android e cheguei até a pensar que a central poderia ser Android mas infelizmente era WinCE.

Os mapas eram os HERE de 2014 e precisavam atualização.
Comecei a procurar na net um executável desbloqueado da mesma versão mas não tive sucesso.
O mais novo que consegui foi o 9.6.13.405512

Subistituí apenas o executável por esse (mantive todo o resto original – data, branding, sys, etc) atualizei os mapas e fui testar.

Tudo funcionava perfeitamente, até mesmo a integração com o “hardware” do carro como bússola e velocímetro.
É muito legal quando paramos dentro do túnel engarrafado e o carrinho também para e só volta a andar quando o carro volta a se movimentar.
Quando pegamos uma bifurcação dentro do túnel e o carrinho vai para o lado certo mesmo sem rota, ou quando andamos num estacionamento no quarto subsolo e o carrinho também se movimenta corretamente!!!

Fiquei muito feliz por algum tempo até que escureceu...

Pois é, quando escureceu, o mapa não mudou para as cores do modo noturno!!!

Voltei com o cartão original e percebí que a as corres do mapa (na versão original bloqueada) também não mudavam quando escurecia


...MAS... quando eu LIGAVA os FARÓIS!!!!! ...interessante...


Voltei com o executável desbloqueado e liguei os faróis... nada o mapa continuava com as cores do dia.

Pensei eu então: “Deve ser alguma coisa no executável original que percebe que eu liguei os faróis e comanda a mudança de cores do mapa”.
O executável desbloqueado não “entende” essa ação e por isso não comanda a mudança de cores.

Algo no DATA ou no BRADING deve desabilitar a mudança de cores pelo horário, aguardando o comando do executável quando eu ligo os faróis.

Fácil vou trocar esses arquivos pela versão do executável desbloqueado...

...Troquei o BRANDING.... o problema continuou...

...Troquei o DATA... o problema continuou...

Pensei então: Que droga!!! Esse pacote deve estar bichado. Vou trocar tudo!!


...Coloquei o Infinity do Cozzi o Ultimate do rafael2san...nada... o problema continuou...


O horário esta correto... o que estaria impedindo o Primo de mudar as cores do mapa no crepúsculo???

Testei vários comandos do sys e suas combinações como:

nightmode_dependent_backlight="0" ou “1”
auto_nightmode="1"

nightmode="1"

backlight_sync_with_OS=1 ou 0

… enfim… nada funcionou…

O que mais me intriga é que mesmo trocando todo o pacote e verificando que o horário esta correto nem mesmo assim o Primo muda de cor ao escurecer...

Alguém tem alguma ideia do que possa estar acontecendo???

Agradeço antecipadamente qualquer ajuda.

Forte Abraço,
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
Última Edição: 29 Mar 2016 17:05 por PPP.
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 29 Mar 2016 17:16 #257109

O que pode estar acontecendo é a central esta dando um "fade" na iluminação da tela, quando você liga o farol.
  • tttmio
  • Usuário Platinum
  • tttmio's Avatar
  • OFFLINE
  • Postagens: 354
  • Agradecimentos: 129
  • Registro em: 28/07/2011
    Ult. Visita: 03/12/2016
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 29 Mar 2016 17:24 #257111

Ela até faz isso mas isso tem apenas o efeito de diminuir o backlight...
Quando ligo os faróis, com o executável original, o mapa realmente muda de cores.
Por exemplo, eu gosto de usar as schemes odystak-day e odstak-night. Na day o mapa é amarelo claro e na night o mapa é verde escuro. Quando ligo os farois com o executável original, a central diminui o brilho da tela E o mapa passa a ficar verde escuro. Com qualquer outro pacote ao ligar os faróis apenas a central diminui o brilho... e o mapa jamais fica verde escuro... mesmo depois de escurecer.
Abs.
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
Última Edição: 29 Mar 2016 17:27 por PPP.
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 29 Mar 2016 22:17 #257125

Caro PP

Intrigante mesmo é esta versão...procurei em todos os fóruns e não localizei nada.Como a NNG tem mais de 150 parceiros em mais de 200 países fica difícil mesmo saber quem desenvolveu este.

Tem como vc publicar de que dia/mês/ano é? ?

Talvez este comando esteja embarcado dentro do executável !

[ ]'s
  • Varelo
  • Usuário Platinum
  • Salve-me! Mico Leão Dourado
  • Varelo's Avatar
  • OFFLINE
  • Postagens: 283
  • Agradecimentos: 626
  • Registro em: 19/03/2012
    Ult. Visita: 20/11/2016
\[..]/
Quando puder agradeça...,pois, "Agradecimento é a única moeda de troca que recebemos por tentar ajudá-los".
ZonaSul - São Paulo - SP
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 30 Mar 2016 07:41 #257127

Com certeza o executável foi compilado exclusivamente para este hardware. Já tive uma CM Alpine em que era possível dividir o uso da tela entre o navegador e as funções normais da CM, ficando meio a meio. Também, ao mudar a cor da iluminação dos botões, automaticamente a cor da scheme do iGO Primo original também mudava e além disso o relógio da CM seguia a hora do navegador e não podia ser acertado de outra maneira. Ao trocar por um navegador desbloqueado não consegui repetir nenhuma destas funções de jeito nenhum!!!

VALEW!!!
  • SPY/DF
  • Usuário Platinum
  • SPY/DF's Avatar
  • OFFLINE
  • Postagens: 319
  • Agradecimentos: 408
  • Registro em: 05/08/2011
    Ult. Visita: 02/12/2016
Última Edição: 30 Mar 2016 07:56 por SPY/DF.
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 30 Mar 2016 16:07 #257145

Caro Varelo,

Claro que posso. A data do release é 13/Mar/2015

Abs!
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 30 Mar 2016 16:12 #257147

caro SPY/DF,

Concordo com tudo o que você falou, com certeza esse executável foi compilado para esse hardware especifico.

Mas uma coisa me intriga mais: Se eu trocar todo o pacote por um desbloqueado (EXE, DATA, Branding, etc) o mapa NÃO muda para as cores noturnas quando escurece apesar do relógio estar marcando a hora local corretamente... Incrível né?...

Abração!
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 31 Mar 2016 07:59 #257161

PPP

Olá, Amighinho!

No pacote original teria um arquivo ".ini" que talvez indicaria esta função.
Pode ser na raiz do cartão de memória.


Ping
  • Ping
  • Colaborador
  • Aprender e compartilhar
  • Ping's Avatar
  • OFFLINE
  • Postagens: 2115
  • Agradecimentos: 1242
  • Registro em: 26/12/2010
    Ult. Visita: 30/07/2016
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 31 Mar 2016 09:25 #257163

Olá BBB e Ping

É provável que exista esse arquivo ini específico para a central em questão.
Se existir, ele deve estar no Data.zip, na pasta Config, subpasta Device.

Existirá também no sys. txt ou no arquivo igo9.ini o direcionamento para o arquivo ini citado, no parâmetro Device.

Como ao substituir o executável do Primo a função sumiu, é provável que o executável original tenha internamente algum comando diferente.
Executáveis com funções novas também costumam ter parâmetros novos, no arquivo igo9.ini. Já fiz experiências adicionando parâmetros novos com executáveis mais antigos e nunca nada funcionou.

Abs
  • luizcarlosrio
  • Moderador
  • luizcarlosrio's Avatar
  • OFFLINE
  • Postagens: 2016
  • Agradecimentos: 926
  • Registro em: 04/07/2011
    Ult. Visita: 30/11/2016
Por favor, não me envie msg privada pedindo ajuda, pergunte aqui no fórum. Minha resposta lhe foi útil
e você faz questão de agradecer? Não escreva uma msg agradecendo, apenas aperte o botão. :)
Última Edição: 31 Mar 2016 09:30 por luizcarlosrio.
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 01 Abr 2016 16:51 #257226

Amigos Ping e luizcarlosrio

No pacote original não temos nenhum arquivo .ini temos dentro do DATA.ZIP na pasta project_config o arquivo jlr_gnsd.ini
Também temos a respectiva chamada a esse ini dentro do sys.txt

[project]
name=jlr_gnsd

O conteudo desse arquivo eu reproduzo abaixo:

!version:0
!include:project_config/igo9.ini,0

[device]
sdcard_name="Storage Card"

[gps]
port=7
baud=9600
send_init=0
set_messages=0

[interface]
automotive=1
volume_slider=0
backlight_slider=0
show_exit=0
green_routing=0
save_persistency_check=1

[sound]
use_os_volume=0
os_volume=50

[scheduler]
logic_burst_length=180
logic_burst_length_low_performance=360

[debug]
skip_eula=0
show_gps_pos=0
;************************

[regional.timezone]
keep_auto_on_error=1
sync_time=0
sync_os_timezone=1
sync_os_timezone_only=1

[regional.timezone]
manual_dst="2"
tzbias="0"
tzdbias="-60"
tzdst="0"
use_auto="0"
use_manual_bias="1"

;************************

[rawdisplay]
screen_x=800
screen_y=480

[folders]
branding_folder=""

;disable device.nng
[device]
device_nng_path_primary="%"
device_nng_path_secondary="%"

[other.driver_profile]
enabled=0

[modules]
IITINER_LIST_MANAGER=""
ITMC_STATION_SELECTOR=""
IFM_STATION_CACHE=""


Alguns comandos eu nunca tinha visto antes...

Abs.
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.

Primo 2.4 9.6.27.503057 Windows CE - Intrigante! 19 Abr 2016 13:04 #257944

PROBLEMA SOLUCIONADO!!!

Amigos, após "bater muito a cabeça" finalmente cheguei a uma solução que posto aqui para se outro membro do forum tiver o mesmo problema.

O problema estava acontecendo porque o fuso horário do WinCE estava ajustado para CHINA gmt+8

Ou seja, o Primo tinha a hora do GPS (GMT) e pela localidade (ajuste em AUTO) sabia que a região onde ele estava era GMT-3 e colocava a hora corretamente mas para mudar a cor do "scheme" ficava confuso de qual fuso usar e não mudava nunca...

Tentei mudar o fuso no WinCE para o de Brasilia mas a cada vez que desligava o carro ele voltava para o chines.

A solução foi então "avisar" ao Primo para desconsiderar o horário do sistema (WinCE) o que foi obtido pelos comandos do SYS abaixo:

[timezone]
default_timezone=19 ;Brasilia
index="19" ; GMT-3 Brasilia
auto_index=19
reset_os_timezone=1
sync_os_timezone=0
use_auto=0
manual_dst=2
tzdst=0
patch_dst=0 (0)

[regional.timezone]
sync_time=0
reset_os_timezone=1
sync_os_timezone=0
sync_os_timezone_only=1
manual_dst="2"
tzbias="0"
tzdbias="-60"
tzdst="0"
use_auto="0"
use_manual_bias="1"

Assim que inseri esses comandos o Primo passou a se "comportar" alterando as cores da "scheme" na alvorada e no crepusculo.

Abraços a todos,
PPP
  • PPP
  • Usuário Gold
  • PPP's Avatar
  • OFFLINE
  • Postagens: 176
  • Agradecimentos: 86
  • Registro em: 26/06/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.280 seconds