Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

Assuntos Diversos
  • Página:
  • 1

TÓPICO: IGO com Nav200 - Delphi

IGO com Nav200 - Delphi 19 Ago 2011 11:00 #87076

Olá pessoal

Tenho um Nav200 - Delphi, seguindo as orientações dos amigos em outros tópicos consegui iniciar o IGO8.3.

- O problema é que não consigo fazer com que o navegador seja iniciado automaticamente quando ligo o GPS ou seleciono o ICONE NAVEG. Atualmente abro o winCE e seleciono a pasta que contem o navegado.

- Outro problema é que as alterações de configuração não são mantidas (Configuração Manual do GPS, Volume...etc), como exemplo ao desligar o GPS não detecta o sinal do satélite, sempre tenho que Auto Detectar de Configuração.

Alguém sabe como resolver estes problemas?

Desde já agradeço a ajuda.
  • binho_free
  • Iniciante
  • binho_free's Avatar
  • OFFLINE
  • Postagens: 3
  • Registro em: 21/07/2011
    Ult. Visita: 16/01/2014
O administrador desabilitou o acesso público de escrita.

Re: IGO com Nav200 - Delphi 26 Ago 2011 17:33 #88544

binho_free,
Vc vai ter que achar o caminho para seu gps se conectar, o navegador está no cartão de memoria? O resto de seus questionamentos estão dentro da pasta do navegador no sys.txt.
Qualquer coisa manda questionamento ai.
  • Caio Junior
  • Galeria de Honra
  • Não mande MP, vamos resolver no forum
  • Caio Junior's Avatar
  • OFFLINE
  • Postagens: 1092
  • Agradecimentos: 913
  • Registro em: 04/04/2011
    Ult. Visita: 27/03/2013
Não mande mp para resolver suas dúvidas



Autorizado pelo autor.
O administrador desabilitou o acesso público de escrita.

Re: IGO com Nav200 - Delphi 30 Ago 2011 15:17 #89305

Olá Caio

O arquivo sys.txt consigo alterar, o problema é fazer o sistema operacional WinCE direcionar a inicialização do aplicativo do IGO8.

Olhando no WinCE não consigo achar nenhum arquivo que eu possa alterar. Será que isso significa que o meu GPS esta bloqueado? ... rssss

Se puder ajudar agradeço mais uma vez.
Abraços.
  • binho_free
  • Iniciante
  • binho_free's Avatar
  • OFFLINE
  • Postagens: 3
  • Registro em: 21/07/2011
    Ult. Visita: 16/01/2014
O administrador desabilitou o acesso público de escrita.

Re: IGO com Nav200 - Delphi 26 Set 2011 20:31 #94670

Olá pessoal

Segue aqui a solução para o caso:


Assunto: Delphi Nav200 + Destinator + MioMap + Route66 + Navigon
Por: rastabr e hectorgrom


"
O botão NAVEG executa o "autorunce.exe" que está dentro do SD.

Decobri o seguinte, dentro da pasta "\Flash Disk\XCommon" tem um arquivo chamado " CONFIG.INI "

Ai estão os path's que são executados.


CONFIG.INI:

[SETTING_INFO]
VERSION=1.15_n
INIT_PROGRAM=0,0,0
LANGUAGE=5,0,0
POPUPSOUND=2,0,0
BUTTONSOUND=3,0,0
GMT=0,32,1

[NAVI_INFO]
TITLE1=Nav200
PATH1=\Storage Card\autorunce.exe
TITLE2=MobileNavigator
PATH2=\Storage Card\MobileNavigator\MobileNavigator.exe
TITLE3=GINI
PATH3=\Storage Card\SpeedNavi_GiNi\bin\GiNi_CX1.exe
TITLE4=Mayowan
PATH4=\Storage Card\Mayowan.exe
TITLE5=TAKARA Destinator TK5
PATH5=\Storage Card\DestinatorApps\Destinator\DestinatorMain.exe
TITLE6=
PATH6=


Será de grande ajuda pra quem quiser rodar o IGO / DESTINATOR / outros direto no botão.


NOTA: se você trocar o patch pra executar outro programa, deve reiniciar o Nav200 pra testar a nova configuração.Sem reiniciar não funciona.

ATENÇÃO - NUNCA troque o "PATH1" se vc trocar o path do "autorunce.exe" não abre mais o explorer, nem o navegador padrão do NAV200 quando vc apertar o botão do navegador, insira um path valido pro seu navegador e renomeie / apague o autorumce.exe do SD. Quando quiser visualizar a estrutura de pastas do WinCE é só copiar o autorumce.exe de volta ou se preferir faça como eu, renomear o "autorunce.exe" para "XWorldClock.exe", e coloque na pasta " \Flash Disk\XWorldClock ",, assim quando você clicar no botão "RELOG. M" ele abre o WinCE - explorer, mesmo sem o cartão SD.
"

Abraços.
  • binho_free
  • Iniciante
  • binho_free's Avatar
  • OFFLINE
  • Postagens: 3
  • Registro em: 21/07/2011
    Ult. Visita: 16/01/2014
Última Edição: 26 Set 2011 20:37 por Wbjiu. Razão: Favor não indicar/mencionar endereços de outros fóruns. É contra as regras do fórum. Grato Wbjiu
O administrador desabilitou o acesso público de escrita.

Re: IGO com Nav200 - Delphi 26 Set 2011 20:41 #94673

binho_free,

Boa noíte!

Editei o seu post acima, pois é contra as regras do fórum mencionar endereços de outros fóruns.
Grato pela sua compreensão!
Abs,

Wbjiu
  • Wbjiu
  • Galeria de Honra
  • "Não enviem Mensagens Privadas"
  • Wbjiu's Avatar
  • OFFLINE
  • Postagens: 2239
  • Agradecimentos: 840
  • Registro em: 11/09/2010
    Ult. Visita: 30/11/2016
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.261 seconds