Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

  • Página:
  • 1

TÓPICO: POR FAVOR ME AJUDEM

POR FAVOR ME AJUDEM 16 Abr 2011 08:01 #63409

Primeiramente Bom dia à todos;

Estou desde omtem tentando configurar meu gps ( bak 4803 ) para ter os tres navegadores no menu inicial, mas estou errando em algum momento que não sei onde, já efetuei toda as alterações informadas aqui do fórum mas não estoou tendo sucesso, colocarei abaixo como esta a configuração do arquivo (config.) da pasta ( ui_480_272) no menu:
#**********************************************
# Ajustes da janela
#**********************************************
GLOBALSETTINGS
ShowMessage = 0
QuitOnDoubleClick = no
X = 0
Y = 0
Width = 480
Height = 272
Arrange = No
BackgroundBitmap = ..\bmp\common\fundo_480_272.bmp
StartUpAnimation = NoAnimation
ShutDownAnimation = NoAnimation
Accelerated = yes
TopMost = no


#**********************************************
# Titulo da janela
#**********************************************
TEXT
x = 175
y = 2
Text = Opções de Navegadores
Color = FFFFFF
FrameColor = 000000
Size = 14
Weight = 500
CreateFont


#**********************************************
# Botão iGO 8.3
#**********************************************
BITMAPBUTTON
x=80
y=71
Command = \SDMMC\igo8.3\igo8.exe
BitmapNormal= ..\bmp\common\BtMenuNW.bmp
BitmapPushed= ..\bmp\common\BtMenuNWP.bmp
QuitOnExecute=no


#**********************************************
# Botão iGO Amigo
#**********************************************
BITMAPBUTTON
x=241
y=71
Command = \SDMMC\amigo\amigo.exe
BitmapNormal= ..\bmp\common\BtMenuNE.bmp
BitmapPushed= ..\bmp\common\BtMenuNEP.bmp
QuitOnExecute=no


#**********************************************
# Botão iGO Primo
#**********************************************
BITMAPBUTTON
x=80
y=128
Command = \SDMMC\primo\primo.exe
BitmapNormal= ..\bmp\common\BtMenuSW.bmp
BitmapPushed= ..\bmp\common\BtMenuSWP.bmp
QuitOnExecute=no


#**********************************************
# Botão Windows
#**********************************************
BITMAPBUTTON
x=241
y=128
Command=\windows\explorer.exe
BitmapNormal= ..\bmp\common\BtMenuSE.bmp
BitmapPushed= ..\bmp\common\BtMenuSEP.bmp


#**********************************************
# Botão Sobre
#**********************************************
BITMAPBUTTON
x=0
y=237
ShutDownAnimation = NoAnimation
NewIni= Sobre.Ini
BitmapNormal= ..\bmp\common\BtSobre.bmp
BitmapPushed= ..\bmp\common\BtSobre.bmp
QuitOnExecute=no


#**********************************************
# Botão Sair
#**********************************************
BITMAPBUTTON
x = 420
y = 237
QuitOnExecute = yes
BitmapNormal= ..\bmp\common\btSair.bmp
BitmapPushed= ..\bmp\common\btSair.bmp



Após iniciar meu gps com essa configuração, ele informa essa mensagem:
(" fehler---das hintergrundbild kann nicht gefunden werden oder es ist keine gultige bitmapdatei:"sdmmc\menu\bmp\common\fundo_480_272.bmp"),



; ;
  • CARDSUL
  • Iniciante
  • CARDSUL's Avatar
  • OFFLINE
  • Postagens: 8
  • Registro em: 31/03/2011
    Ult. Visita: 15/06/2011
Última Edição: 16 Abr 2011 08:15 por CARDSUL.
O administrador desabilitou o acesso público de escrita.

Re: POR FAVOR ME AJUDEM 16 Abr 2011 08:16 #63415

Bom dia,

O teu Shell.ini da pasta raíz do SD está com a descrição \sdmmc\Menu.exe?

O menu.exe está na raíz do SD?

Certifique tb se o teu SysInfoSettings.ini da pasta raíz tem a descrição ui_480_272\Config.ini

Só não entendi porque vc criou outro tópico, hehe...
  • delhmc
  • Colaborador
  • delhmc's Avatar
  • OFFLINE
  • Postagens: 372
  • Agradecimentos: 5
  • Registro em: 16/01/2011
    Ult. Visita: 14/04/2016
Última Edição: 16 Abr 2011 08:30 por delhmc.
O administrador desabilitou o acesso público de escrita.

Re:POR FAVOR ME AJUDEM 16 Abr 2011 08:43 #63420

Bom dia Amigo;

verifiquei o arquivo SysinfoSettings.ini e nesse esta tuco ok,

Desculpe pela minha falta de experiência, mas quanto a sua outras duas perguntas se eu entendi vc quer saber se o arquivo menu esta dentro do meu cartão sdmmc? é isso? se for essa a sua pergunta este arquivo esta dentro dele mesmo;

Quanto a sua pergunta:
O teu Shell.ini da pasta raíz do SD está com a descrição \sdmmc\Menu.exe?

Não entendí, voçê poderia me explicar como confiro onde esta Shell.ini e se este arquivo esta com a descrição correta?, sou novo neste assunto de gps, mas já baixei por aqui os navegadores igo 8.3, amigo e o primo onde em separadamente todos rodam numa boa, mas para unì-los neste menu estou tomando uma tremenda surra!!!!

Estou com meu cartão sdmmc conectado ao meu pc, onde dessa maneira faço todas as alterações, não sei ao certo como localizar a pasta raiz,é preciso o cartão esta dentro de gps? e o gps precisa estar ligado ao pc via cabo usb? ou posso continuar fazendo as atualizações pelo cartão direto no pc?

Desde já agradeço pela atenção.

Att: Anderson Camargo.
  • CARDSUL
  • Iniciante
  • CARDSUL's Avatar
  • OFFLINE
  • Postagens: 8
  • Registro em: 31/03/2011
    Ult. Visita: 15/06/2011
O administrador desabilitou o acesso público de escrita.

Re:POR FAVOR ME AJUDEM 16 Abr 2011 08:51 #63423

Geralmente quando apontamos/configuramos o caminho do navegador (Pasta + Executável) via menu principal do GPS, um arquivo chamado SHELL.INI é criado na pasta raíz (Seja na memória interna do GPS ou no SD). Vc fez esta configuração no menu principal do GPS, apontando para \SDMMC\Menu.exe?

Vc descompactou o pacote do menu personalizado no SD? Este pacote precisa ficar no SD também.
  • delhmc
  • Colaborador
  • delhmc's Avatar
  • OFFLINE
  • Postagens: 372
  • Agradecimentos: 5
  • Registro em: 16/01/2011
    Ult. Visita: 14/04/2016
O administrador desabilitou o acesso público de escrita.

Re: POR FAVOR ME AJUDEM 16 Abr 2011 19:08 #63520

Alguém poderia por gentileza, colocar aqui no fórum a fórmula com os comandos corretos como deve ser editado do arquico ( confg.) da pasta menu, levando em consideração que os meus navegadores ( igo8.3 ) ( amigo ) e ( primo )estão no meu cartão sdmmc, a pasta menu também está.

tenho dúvidas se no arquivo confg. devo alterar os "".." da frente do comando: ( BackgroundBitmap = ..\bmp\common\fundo_480_272.bmp), devo colocar a chamada sdmmc\menu n rente desta linha sem os ".." faz diferença letras maiúsculas de minúsculas? Peço desculpas por minha falta de experiêsncia.

Fico no aguardo.

Anderson Camargo.
  • CARDSUL
  • Iniciante
  • CARDSUL's Avatar
  • OFFLINE
  • Postagens: 8
  • Registro em: 31/03/2011
    Ult. Visita: 15/06/2011
O administrador desabilitou o acesso público de escrita.

Re: POR FAVOR ME AJUDEM 17 Abr 2011 04:32 #63567

Bom dia Anderson,

A notação ..\bmp\common\fundo_480_272.bmp é o que chamamos de caminho relativo. Os dois pontinhos significam "um nível acima" na estrutura de diretórios. No caso específico, como o script está dentro de um subdiretório de "menu", o ".." é equivalente à própria pasta do menu, esteja onde estiver e seja qual o seu nome. O motivo de eu ter usado esta notação foi eliminar a necessidade de ajustes no script, nas especificações dos bitmaps dos menus, em função da nomenclatura da unidade de memória do GPS do usuário.

O comando poderia ter sido assim:

BackgroundBitmap = \SDMMC\menu\bmp\common\fundo_480_272.bmp

Mas, aí, se o menu não estiver rodando em SDMMC, teríamos aí mais uma porção de ajustes a fazer, um para cada referência a cada um dos bitmaps do menu. Veja as possibilidades:

BackgroundBitmap = \SDMMC\menu\bmp\common\fundo_480_272.bmp
BackgroundBitmap = \Storage Card\menu\bmp\common\fundo_480_272.bmp
BackgroundBitmap = \ResidentFlash\menu\bmp\common\fundo_480_272.bmp
BackgroundBitmap = \My Flash Disk\menu\bmp\common\fundo_480_272.bmp, etc.

O uso da notação de caminho relativo elimina essa camada de configuração do menu.

Quanto ao uso de maiúsculas/minúsculas: sim, é possível que o WinCE diferencie entre estas, por isso aconselho fazer um copy/paste do menu original. Já vi casos até de um espaço em branco esquecido no início da linha de comando do arquivo config.ini atrapalhar o comando. Na dúvida, use os comandos rigorosamente da forma como estão no config.ini do menu original.

A mensagem de erro que você postou significa que o Windows CE não encontrou o bitmap de fundo, da forma como está especificado no config.ini. Das duas, uma: ou o caminho/nome do arquivo estão incorretos, ou o arquivo não existe/está corrompido na pasta common. Já tentou substituir o bitmap em questão por uma cópia nova?

BBL
  • BrunoBL
  • Gerente
  • Joinville - SC
  • BrunoBL's Avatar
  • OFFLINE
  • Postagens: 5070
  • Agradecimentos: 1616
  • Registro em: 11/06/2010
    Ult. Visita: 07/12/2016
Toda ajuda é feita via fórum. Não envie pedido de ajuda por mensagem privativa.
Clique aqui para ajudar a manter o GPSPoint no ar
Última Edição: 17 Abr 2011 05:17 por BrunoBL.
O administrador desabilitou o acesso público de escrita.

Re:POR FAVOR ME AJUDEM 18 Abr 2011 13:08 #63880

Boa tarde bruno;

Agradeço pela atenção dada ao meu caso, onde felismente consegui atualizar meu gps com os três menus na tela inicial, após muita persistência tive sucesso, não sei o que estava fazendo de errado, mas segui sua sugestão, apaguei toda pasta " menu " do meu cartão e começei do zero, onde por felicidade minha consegui.
Deixo aqui registrado meus agradecimentos sinceros por poder contar com os amigos deste fórum, e mais uma vez me ponho à disposição para ajudar a manter esse fórum sempre ativo.

Grande abraço;

Att;

Anderson Camargo.
  • CARDSUL
  • Iniciante
  • CARDSUL's Avatar
  • OFFLINE
  • Postagens: 8
  • Registro em: 31/03/2011
    Ult. Visita: 15/06/2011
O administrador desabilitou o acesso público de escrita.

Re:POR FAVOR ME AJUDEM 18 Abr 2011 13:28 #63887

Que bom Anderson!!!

Abs
  • delhmc
  • Colaborador
  • delhmc's Avatar
  • OFFLINE
  • Postagens: 372
  • Agradecimentos: 5
  • Registro em: 16/01/2011
    Ult. Visita: 14/04/2016
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.327 seconds