Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

  • Página:
  • 1

TÓPICO: Monitor de viagem com problema.

Monitor de viagem com problema. 12 Out 2011 23:24 #98519

Olá pessoal !

No meu primo 1.2, quando eu chego no destino final de uma rota, ele grava os dados da rota no monitor de viagem.

Esses dados ficam no gps para posterior consulta. Mas quando eu desligo o gps e ligo novamente, esses dados são apagados !

Existe algum comando para isso não acontecer ? Não quero perder os dados gravados.

Obrigado !
  • portesjunior
  • Usuário Platinum
  • portesjunior's Avatar
  • OFFLINE
  • Postagens: 290
  • Agradecimentos: 12
  • Registro em: 11/07/2010
    Ult. Visita: 27/09/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 14 Out 2011 21:56 #98868

Seria isso? http*//www.gpsbra.com/forum/viewtopic.php?f=144&t=8866 (tire o * da url)
Passei por isso em um Airis E435
  • lincolm_aguiar
  • Iniciante
  • lincolm_aguiar's Avatar
  • OFFLINE
  • Postagens: 14
  • Agradecimentos: 1
  • Registro em: 29/10/2010
    Ult. Visita: 09/08/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 14 Out 2011 23:02 #98873

Pessoal,

Copiei minha resposta que tinha passado no gpsbra sobre este mesmo assunto.

Olá pessoal,

Resolvido!!

Há um problema em algum setor da memória residente do Airis E435 que impede que os arquivos na pasta TRACKS sejam devidamente gravados. Seria necessária uma ferramenta mais apurada do que as ferramentas de manuteção de discos do Windows 7 para ver o caso, mas esta é a minha conclusão.

Cheguei a este resultado fazendo o primo usar uma pasta save externa ao diretório de instalação, deixo o primo na memória residente e a pasta save, apenas, fica no cartão. Com isto os registros foram devidamente salvos. Abaixo a configuração utilizada no sys.txt:

[folders]
has_secondary_root="0"
data="%SDCARD%\Primo"

Um comportamento que pode ter levado ao problema era o botão no primo para desligá-lo. No Navman F25 esta função não desligava o primo, não fazia nada. No Airis ela funciona mas assim que eu fazia e ligava novamente o primo perdia toda a configuração da pasta save, reportava aquela mensagem de que a aplicação fechou de maneira anormal e que todas as configurações e POIs seriam perdidos. No Windows 7, acessando o dispositivo pelo USB, quando eu desligava o primo pelo botão do primo, no Windows 7 alguns arquivos da pasta save ficavam como que abertos e impossíveis de serem apagados. Era necessário dar um reset no aparelho e então usar as ferramentas do Windows 7 para formatar o aparelho corrigindo os setores defeituosos.

Eu havia usado o botao de desligar por algumas vezes até porque não era sempre que dava o erro de perder a configuração, mas quando ocorria, perdia tudo mesmo, só formatando o dispositivo novamente. Na época eu imaginava ser branding.zip que eu havia pegado no site naquele dia que instalei o primo. Depois pensei que tinha sido a atualização do skin GJA, Dimka, tudo. Na versão original do Airis, que veio com o Amigo, tudo ficava sempre 100%, mas percebi que lá não tinha o botão de desligar o primo!

Então, eu impedi a exibição das funções de desligar o primo no sys.txt e usei o botão do aparelho mesmo para desligá-lo. Seria como se desligasse o computador sempre pelo botão, sem fechar o windows, mas veja que esta era a solução! A partir do momento que adotei este comportamento, o primo nunca mais reportou erro da pasta save e nenhum arquivo nela gravado ficava como aberto.

Usei as configurações abaixo no sys.txt:

[interface]
vga="0"
show_exit="0"
show_minimize="0"

Com isto pessoal, eu não tenho mais problemas no primo. Hoje ele funcionou 100% salvando os trechos e permitindo consulta após religar o primo.

Os relatos deste tópico são bem pertinentes a quem teve problemas com perdas de dados no primo, ou mesmo outras versões, pois o erro era de problema no meio de armazenamento e isto pode afetar qualquer versão, até mesmo de outros softwares de navegação. O problema pode não ser o mesmo, mas as informações de identificação da causa problema podem elucidar outros problemas ou ajudar a quem estiver passando por eles.
  • lincolm_aguiar
  • Iniciante
  • lincolm_aguiar's Avatar
  • OFFLINE
  • Postagens: 14
  • Agradecimentos: 1
  • Registro em: 29/10/2010
    Ult. Visita: 09/08/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 15 Out 2011 15:31 #98982

lincolm

fiz o procedimento que você falou, mas nao adiantou.

quando eu saio do navegador e entro novamente, os dados que estavam gravados do monitor de viajem somem.
  • portesjunior
  • Usuário Platinum
  • portesjunior's Avatar
  • OFFLINE
  • Postagens: 290
  • Agradecimentos: 12
  • Registro em: 11/07/2010
    Ult. Visita: 27/09/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 17 Out 2011 23:35 #99517

O que ocorreu? Você verificou se ficaram arquivos zerados na pasta tracks?
  • lincolm_aguiar
  • Iniciante
  • lincolm_aguiar's Avatar
  • OFFLINE
  • Postagens: 14
  • Agradecimentos: 1
  • Registro em: 29/10/2010
    Ult. Visita: 09/08/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 17 Out 2011 23:38 #99520

A pasta tracks volta a ficar vazia
  • portesjunior
  • Usuário Platinum
  • portesjunior's Avatar
  • OFFLINE
  • Postagens: 290
  • Agradecimentos: 12
  • Registro em: 11/07/2010
    Ult. Visita: 27/09/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 18 Out 2011 20:41 #99731

Então é pior. Não há configuração modificando a localização da pastas save? Se você a renomear, por exemplo, para save_ . Quando você ligar o primo novamente ele a criará. Você terá que redefinir todos os parâmetros de configuração: regional, tts, veículo, etc..Mas recomendo fazer para verificar se a nova pasta criada estará no local esperado para ela estar, ou seja, onde você verificou que a pasta tracks está vazia.
Deixando o primo ligado, habilite o computador de viagem para salvar automaticamente a rota e então ele irá começar a gravar registros de posição, mesmo sem estar em movimento. A meta não é ter registros de deslocamento, já que não haverá, mas verificar se a pasta tracks terá arquivos trk criados.
  • lincolm_aguiar
  • Iniciante
  • lincolm_aguiar's Avatar
  • OFFLINE
  • Postagens: 14
  • Agradecimentos: 1
  • Registro em: 29/10/2010
    Ult. Visita: 09/08/2015
O administrador desabilitou o acesso público de escrita.

Re: Monitor de viagem com problema. 18 Out 2011 21:15 #99738

lincolm..

fiz um teste hoje durante o dia e descobri algo interessante:

depois de ter terminado ma rota, fui até o monitor de viagem e renomeei o arquivo que ele criou. (Trajeto 001 para TESTE)

feito isso , eu desliguei o GPS e liguei novamente.

o arquivo estava lá !! não apagou !

repeti o procedimento com mais duas rotas que fiz no período da tarde e todas as rotas ficaram lá !!

não sei por que acontece isso de ele apagar o arquivo se nao renomea-lo.

obrigado pela força amigão !!
  • portesjunior
  • Usuário Platinum
  • portesjunior's Avatar
  • OFFLINE
  • Postagens: 290
  • Agradecimentos: 12
  • Registro em: 11/07/2010
    Ult. Visita: 27/09/2015
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.307 seconds