Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

  • Página:
  • 1

TÓPICO: Problema de Out Of Memory com Primo

Problema de Out Of Memory com Primo 30 Jan 2013 21:36 #185768

Boa noite,

Bom pessoal estou com um problema do famoso "Out Of Memory" quando tento executar o Primo v8.5.9 isso começou depois que atualizei o speedcam a mensagem de erro é a seguinte:

Out Of Memory.
Requesited: 23592960
Cache: 0

depois que li o tópico abaixo que encontrei na pesquisa fiz conforme as instruções ai a mensagem de erro alterou para
www.gpspoint.com.br/...seu-igo-primo#179566

Out Of Memory.
Requesited: 11796480
Cache: 0

mas continua não abrindo o Primo, alguém sabe ou tem uma dica de como posso resolver esse impasse do famoso "Out Of Memory"

Agradeço quem poder me ajudar desde já Obrigado.
  • Amoriello
  • Colaborador
  • Amoriello's Avatar
  • OFFLINE
  • Postagens: 2007
  • Agradecimentos: 891
  • Registro em: 03/07/2011
    Ult. Visita: 03/12/2016
GPS Siga-Me Imagem Primo 2.0.1
GPS Airis E350 iGO Amigo
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 30 Jan 2013 21:45 #185770

Amoriello

Parte da mensagem está oculta para visitantes. Por favor faça login ou se registre para vê-la.
Abs.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
Última Edição: 30 Jan 2013 23:13 por Foxtrot.
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 30 Jan 2013 22:32 #185776

Foxtrot obrigado pela ajuda,

seguindo as dicas do buga2003 e usando Resinfo.exe para descobrir o valor da Memoria do meu Siga_Me Imagem o resultado foi os dados abaixo
total= 118MB
22.3MB used 96.0MB free
23383244.8 100663296

seguindo o raciocínio seria isso 23383244-1500000-2048= 21881196
"max_memory=21881196", então esse foi o valor encontrado para o meu GPS mas mesmo assim não deu certo, antes o sys.txt não tinha esse comando na aba [debug] inseri para testar e ver se daria certo e resolveria o problema mas sem sucesso, os outros navegadores estão rodando normal só esse que não quer rodar, mas antes de atualizar o speedcam tava rodando normal também, apaguei o recoloquei o Backup pra ver se não teria corrompido algum arquivo mas nem o Backup quer rodar, eu estava
testando o Garmin nesse GPS será que foi isso? pois o garmin executa o WinCE primeiro para rodar o garmin, tirei o Garmin e resetei o GPS pra ver se não teria mais algum programa sendo executado junto com o Primo para estar dando falta de Memoria, mas mesmo assim não vai, quando chamo o Primo começa a carregar e em seguida entra a mensagem de "Out Of Memory"
  • Amoriello
  • Colaborador
  • Amoriello's Avatar
  • OFFLINE
  • Postagens: 2007
  • Agradecimentos: 891
  • Registro em: 03/07/2011
    Ult. Visita: 03/12/2016
GPS Siga-Me Imagem Primo 2.0.1
GPS Airis E350 iGO Amigo
Última Edição: 30 Jan 2013 22:34 por Amoriello.
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 30 Jan 2013 22:47 #185778

Amoriello

Sendo se aparelho de 128Mb de RAM, o que é um sonho de consumo meu rsrs, esse erro não deveria ocorrer. Ele é normal em aparelhos de 64Mb, mas no seu é quase que um mistério o fato de ele estar ocorrendo.

Experimente não usar linha alguma no sys.tx que se refira a reserva de memória (coloque um ponto e virgula na frente das 3 linhas que o colega Foxtrot passou), para que o próprio Primo faça o gerenciamento de memória.

Também, caso não dê certo. experimente renomear a pasta SAVE para SAVE_OLD e reinicie o aparelho. Se funcionar, vc precisará reconfigurar o navegador.
  • plot_aqa
  • Gerente
  • Evite Mensagens Privadas para dúvidas. Pesquise!
  • plot_aqa's Avatar
  • OFFLINE
  • Postagens: 7801
  • Agradecimentos: 4072
  • Registro em: 02/08/2010
    Ult. Visita: 23/04/2015
CLIQUE AQUI e Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar !

POR FAVOR, DÚVIDAS APENAS NO FORUM!!!

NÃO EXISTE ATENDIMENTO V.I.P., PORTANTO NÃO ENVIEM MP COM DÚVIDAS TÉCNICAS
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 30 Jan 2013 23:01 #185782

Boa noite plot,

renomeei a pasta save e coloquei ponto e virgula nas linhas referidas, e também reconfigurei o Siga-Me para chamar o Primo direto até pra não consumir memoria com Menu Personalizado, mas mesmo assim não deu ele carrega até o ponto de selecionar a Lang dai já da o erro, ta virando um mistério.
  • Amoriello
  • Colaborador
  • Amoriello's Avatar
  • OFFLINE
  • Postagens: 2007
  • Agradecimentos: 891
  • Registro em: 03/07/2011
    Ult. Visita: 03/12/2016
GPS Siga-Me Imagem Primo 2.0.1
GPS Airis E350 iGO Amigo
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 30 Jan 2013 23:06 #185785

Amoriello, boa noite.

1. Renomeie a pasta Speedcam para Speed2, crie outra pasta Speedcam e coloque dentro dela os arquivos TXT que vão gerar os alertas e radares. Daí reinicie e teste

2. Se o item 1 não funcionar, experimente colocar o navegador na memória interna. Se não der erro, provavelmente seu cartão está com algum problema e daí formate-o e volte a colocar o conteúdo. Em última hipótese, use outro cartão
  • plot_aqa
  • Gerente
  • Evite Mensagens Privadas para dúvidas. Pesquise!
  • plot_aqa's Avatar
  • OFFLINE
  • Postagens: 7801
  • Agradecimentos: 4072
  • Registro em: 02/08/2010
    Ult. Visita: 23/04/2015
CLIQUE AQUI e Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar !

POR FAVOR, DÚVIDAS APENAS NO FORUM!!!

NÃO EXISTE ATENDIMENTO V.I.P., PORTANTO NÃO ENVIEM MP COM DÚVIDAS TÉCNICAS
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 30 Jan 2013 23:08 #185786

Amoriello

Pensei que era um 64mb! Por isso a instruçao anterior.
O primo 'default' é automatico 'max_memory' =: 400xxxxxxxxx
Faça o indicado pelo colega Plot, isso seria o inicial e creio que vc ja deva ter feito.
Parte da mensagem está oculta para visitantes. Por favor faça login ou se registre para vê-la.
4-Se nao funcionar, escomungue o Garmim...lol

Ps.- O Sygic as vzs faz isso tbm.

Abs.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
Última Edição: 30 Jan 2013 23:12 por Foxtrot.
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: plot_aqa

Re: Problema de Out Of Memory com Primo 31 Jan 2013 02:05 #185795

Amoriello

Em meus testes descobrir que o "Out Of Memory" só acontece quando uso alguma voz TTS ou TTS Pro. Usando uma voz normal os navegadores rodam de boa. Faça um teste aí para ver se consegue ter êxito.

Outra alternativa é usar o StartWin para acessar o "menu interno" do aparelho e liberar espaço no próprio aparelho, segue uma dica do Neoss75 (fórum russo):
tente liberar memória antes de executar, mesmo nas propriedades do sistema, há um controle deslizante para substituir a memória, movê-lo, ver a tela (imagem) abaixo:



Abraços







Abraços.
  • d780
  • Colaborador
  • d780's Avatar
  • OFFLINE
  • Postagens: 542
  • Agradecimentos: 558
  • Registro em: 15/01/2011
    Ult. Visita: 02/12/2016
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 13:23 #185815

d780

Claro, retirando-se o que 'pesa' se economiza memoria.
Se tirar o DEM, Poi's, etc, tbm ajuda.
Mas neste caso, tudo funcionava bem, conforme o descrito.
Entao nao e o caso de se 'enxugar' os superfluos, mas sim de voltar a condiçao inicial/funcional,
ate pq e um aparelho com 128mb de RAM e suporta bem os 'superfluos'..

Obrigado por postar as imagens referentes a minha recomendaçao numero 3 do meu post acima.

Abs.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 13:38 #185816

Amoriello

Qual o tamanho final do novo "speedcam.spdb" ?

Quanto tem de espaço livre no local em que está instalado este Primo 8.5.9 ?

Poderia dar um COPY/PASTE no sys.txt dele aqui ?

:)

Sk
  • Sherlock
  • Gerente
  • Sherlock's Avatar
  • OFFLINE
  • Postagens: 5958
  • Agradecimentos: 8098
  • Registro em: 04/09/2010
    Ult. Visita: 28/11/2016
Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar!
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 14:02 #185819

Sherlock

Uma vez tive um problema parecido e 'apanhei' mto ate descobrir o .spud corrompido
na pasta speedcam, e nem deleta-lo era possivel! Formatei, verifiquei e nada, ele sempre voltava corrompido!
Voltei as 'configuraçoes originais do navegador', troquei de SD (original de marca) e resolveu.
Talvez nao seja isso, mas...Pode ser algo parecido ai tbm, vale deletar o .spud e ver o que acontece.

Abraços amigo.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: Sherlock

Re: Problema de Out Of Memory com Primo 31 Jan 2013 17:03 #185829

Foxtrot, Sherlock

Por isso que minha primeira recomendação foi criar outra pasta SpeedCam, de maneira que seja gerado um novo SPDB, descartando um eventual arquivo corrompido.
  • plot_aqa
  • Gerente
  • Evite Mensagens Privadas para dúvidas. Pesquise!
  • plot_aqa's Avatar
  • OFFLINE
  • Postagens: 7801
  • Agradecimentos: 4072
  • Registro em: 02/08/2010
    Ult. Visita: 23/04/2015
CLIQUE AQUI e Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar !

POR FAVOR, DÚVIDAS APENAS NO FORUM!!!

NÃO EXISTE ATENDIMENTO V.I.P., PORTANTO NÃO ENVIEM MP COM DÚVIDAS TÉCNICAS
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 17:11 #185831

Amoriello,


Considerando que o problema se iniciou a partir da atualização da pasta speedcam, e a dica no post #6255 do WORDFISH, nestes termos:

"Pessoal,
Acredito que todos acabam passando por este problema que é instalar os navegadores acima no mesmo cartão de memoria e quando vai rodar o Primo ocorrem varios erros de inicialização. O problema é o seguinte o Primo quando inicializa faz uma varredura nos drives do aparelho procurando a pasta content e tenta carregar os arquivos desta pasta, então se voce tem o Igo ou o Amigo no cartão quando ele acessa a pasta ocorrem os erros. Para resolver este problema e manter os navegadores instalados basta somente alterar o nome da pasta content para qualquer outro nome e o Primo roda tranquilo, quando quiser iniciar o Igo basta renomear a pasta para "Content" de novo e pronto. Abçs....Wordfish".

Observação: (grifo nosso)

www.gpspoint.com.br/...go-e-primo-no-cartao

vale a pena tentar isso (renomear a pasta Content), caso o problema (falta de memória) já não tenha sido resolvido por outra forma.

Abs.

NNunes.
  • NNunes
  • Moderador
  • NNunes's Avatar
  • ONLINE
  • Postagens: 1835
  • Agradecimentos: 725
  • Registro em: 15/09/2011
    Ult. Visita: 03/12/2016
Última Edição: 31 Jan 2013 17:15 por NNunes.
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 18:17 #185835

plot_aqa

Claro amigo, vc esta certo.
Tem que fazer isso mesmo qdo o problema aparece apos atualizaçoes de alertas.

Mas o que eu citei no meu ultimo post se refere ao .spud e nao ao .spdb.
Ele se 'criava' limpo, sem nada, na nova pasta Speedcam ja corrompido e travava o navegador!
Pior, nao deletava! Era preciso usar o 'scan' e reparo do Windows no cartao, ai encontrava uma entrada invalida
e a excluia, SD limpo, formatava. De novo reiniciava e....la estava ele corrompido e sem poder excluir deletando!
Ate hoje eu nao entendi direito e claro o que aconteceu naquele caso...lol..

Abraços amigo.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 18:52 #185841

NNunes

Renomear a pasta 'content' nao me parece logico.

Se usar assim no sys.txt isso nao ocorre:
(se eu entendi direito o que foi dito)

Parte da mensagem está oculta para visitantes. Por favor faça login ou se registre para vê-la.
Abs.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 20:07 #185846

Boa tarde a todos,

problema resolvido, bom usei a dica do plot, renomear a pasta speedcam e criar outra, continuou a falta de memória, também usei a dica de renomear a pasta save para criar outra também não adiantou, ai usei a dica do Foxtrot modificar a memória do aparelho como nas imagens postada pelo d780 também não resolveu, parti para dica do plot de por o Primo na memória interna e executei também não foi, com o Primo na memória interna tirei o SD Card e executei novamente ai sim conseguiu carregar, para testar coloquei o SD Card de volta e executei novamente para tirar a prova não carregou, então pela conclusão o problema esta no SD Card, então formatei o SD Card e recoloquei o Primo no SD e reiniciei ai carregou, isso foi feito ontem, hoje recoloquei todo os navegadores no SD Card de volta e como era um Backup que eu tinha guardado tive que atualizar tudo novamente, todos atualizaram normal mas o Primo v8.5.9 voltou o problema da falta de memória, e hoje eu usei ele o dia todo e não teve problema nenhum, voltei novamente para memória interna pra testar com o SD Card inserido não carrega da "Out Of Memory" sem o SD Card carrega normal cria o speedcam e funcionando tudo certinho, agora fica o mistério o meu SD Card é um "SanDisk Ultra 16GB serie 10" no momento está com 5.95GB de espaço livre e 14.82GB usado, fiquei pensando um pouco e relendo esse tópico ai me bateu de verificar o sys.txt pra ver se tinha a aba [folders] que o Foxtrot comentou e realmente não tinha, então já coloquei e reiniciei foi até mais rápido do que eu estava acostumado, então fica a dica pra quem tem vários navegadores em um Cartão SD colocar em todos a aba [folders] para ele ler somente seus arquivos.
Obrigado a todos que contribuiu para a solução desse problema que com certeza vai ajudar muitos amigo aqui do Fórum.
  • Amoriello
  • Colaborador
  • Amoriello's Avatar
  • OFFLINE
  • Postagens: 2007
  • Agradecimentos: 891
  • Registro em: 03/07/2011
    Ult. Visita: 03/12/2016
GPS Siga-Me Imagem Primo 2.0.1
GPS Airis E350 iGO Amigo
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: plot_aqa, Foxtrot

Re: Problema de Out Of Memory com Primo 31 Jan 2013 20:46 #185848

Sherlock, o espaço livre está no poste acima e o sys.txt esta em anexo aqui pra você dar uma olhada, mas pelo menos problema resolvido.
Anexos:
  • Amoriello
  • Colaborador
  • Amoriello's Avatar
  • OFFLINE
  • Postagens: 2007
  • Agradecimentos: 891
  • Registro em: 03/07/2011
    Ult. Visita: 03/12/2016
GPS Siga-Me Imagem Primo 2.0.1
GPS Airis E350 iGO Amigo
O administrador desabilitou o acesso público de escrita.

Re: Problema de Out Of Memory com Primo 31 Jan 2013 22:20 #185852

Amoriello, Pessoal

Um dos 'problemas' de sabermos um pouco mais do que o normal em qualquer area
é que começamos a pensar 'complicado', e nos esquecemos do basico pq achamos que todos
o sabem ou ja o fizeram. Nem sempre e assim e este e um caso tipico destas ocorrencias que
nos passam desapercebidas ao tentar ajudar a distancia sem ver. Enfim, problema resolvido facil.

A citaçao do NNunes despertou o basico, e por isso postei o [folders], mas confesso, achando que
ja estava assim no navegador/problema 'investigado'. Preciso aprender a pensar 'simples e basico'..lol

Meritos a todos nós, mas em especial ao NNunes e ao SK que pediu o sys.txt e ai ja veriamos isso.

Abs extensivos.
  • Foxtrot
  • Usuário Platinum
  • Pesquise Sempre!
  • Foxtrot's Avatar
  • OFFLINE
  • Postagens: 2054
  • Agradecimentos: 506
  • Registro em: 16/12/2011
    Ult. Visita: 26/03/2013
Antes de Criar Topicos, Por Favor Leia: migre.me/a9whV
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: Amoriello

Re: Problema de Out Of Memory com Primo 04 Fev 2013 18:06 #186126

Amoriello

1) Tem certeza que seu data.zip tem o "A5003V.ini" dentro da pasta \devices\

[device]
type="A5003V"

Se tiver, remova as chaves [gps] , [power] do sys.txt

Se não tiver, ou você copia e remove as chaves , ou troca o [device] para o genérico e mantem as definições lá no sys.txt

[device]
type="generic_device"

Obs.: o motivo de eu questionar se tem é que meu 8.5.9 tem somente 6 dispositivos no data.zip ! Além disso o T503 não existia na época do navegador

2) O T503 não suporta TMC , remova também a chave [tmc]

isso vai inclusive aliviar a memória do Primo

3) Separe as chaves [sound] e [ding]

[sound]
ding=0
[other]
demo_enabled=0

4) Na época do Primo 8.5.9 ainda não havia Speed Profiles. Retire este parâmetro futurista do [route] ... rs

[route]
planned_route_weight=9 ;7
correctness=95 ;88
;speed_profile_weight=80 ;100
;fixed_correctness= ;?
slow_car_speed=60 ;(80) eta, route time calc?
slow_car_multiplactor=80 ;(80)
fast_car_speed=100 ;(130)
fast_car_multiplactor=100 ;(100)
motorcycle_speed=120 ;(130)
motorcycle_multiplactor=100 ;(100)
offroad_speed=20 ;(30)
continue_with_ferry=1 ;(0)

5) Os parâmetros "repetidos" em TODOS os [speedcam_category: ] podem ser inseridos uma única vez na chave [warning] e removidos de TODOS os [speedcam_category: ]

Exemplo:

[warning]
Approach_beep_tonal_type = "1" ;ou 0
is_spoken="1"
mute_voice_announce_during_alert="1"
overspeed_min_speech_repeat_delay = "-1"; não repetir
overspeed_min_tone_repeat_delay = "-1"; não repetir
section_beep_sound="!alert4"
send_warn_event="1"
speedcam_enabled="1"
speedcam_max_angle="55"
speedcam_maxdistance_from_road="45"
speedcam_max_lookahead="1000"
speedcam_soundtype="2"
speedcam_soundtype_3="1"
speedcam_soundtype_8="2"
speedcam_visualtype="1"
;speedcam_warning="1"
speedcam_warning="all" ; speedcam types
speedlimit_warning_visual="1"
speedlimit_warning_voice="1"
speedwarn_toltype="1"
speedwarn_tolerance="100"
speedwarn_alt_toltype="1"
speedwarn_alt_tolerance="100"
warn_distances="120:750,110:700,100:650,90:600,80:550,70:500,60:450,50:400,40:350,30:300,20:250,10:200"
approach_beep_distances="10,25,50,100,150,200,250,300,350,400"

6) Reduza o buffer do TTS para aquilo que o TTS realmente precisa (=42MB)

[tts]
tts_buffer=43008

7) Remova o parâmetros desnecessários
[interface]
enable_stateanim=0
default_anim_off=1
uieffect_enabled=1
night_mode_altitude=1
;show_exit=1
resolution_dir="480_272"
;vga=0

8) O Primo 8.5.9 gerenciava mal a memória. Vale à pena usar os parâmetros de otimização, mesmo com 128 MB

[debug]
cache=10485760
max_memory=480000000
reserve_memory="3670016"

9) Não sei que versão TTS está usando. Sugiro a Gabriela 1.14 . Para ela anunciar o nome das ruas , altere para "3" estes dois parâmetros

[tts]
announce_exit_directions="3"
always_say_road_names="3"

10) vodka ... muita vodka
Boa sorte !

;)

Sk
  • Sherlock
  • Gerente
  • Sherlock's Avatar
  • OFFLINE
  • Postagens: 5958
  • Agradecimentos: 8098
  • Registro em: 04/09/2010
    Ult. Visita: 28/11/2016
Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar!
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.350 seconds