Bem-Vindo, Visitante
Username: Password: Lembrar-me

Pesquisa no Fórum

  • Página:
  • 1

TÓPICO: IgoPrimo 2.0 - skin

IgoPrimo 2.0 - skin 17 Set 2012 19:47 #172597

Amigos me ajudem.... porque os icones saem pela metade... meu gps apontador t500,
Estou usando o skin zozo 2.o - gps apontador t500. Grato
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
Última Edição: 17 Set 2012 20:28 por walmirpinto.
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: firmino 6384

Re: IgoPrimo 2.0 - skin 17 Set 2012 21:04 #172620

Pode ser o seu arquivo branding.zip
Esperimente renomea-lo para branding.old e entrar no navegador.
Veja se resolve.
  • shdw
  • Colaborador
  • shdw's Avatar
  • OFFLINE
  • Postagens: 635
  • Agradecimentos: 243
  • Registro em: 14/09/2010
    Ult. Visita: 05/12/2016
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 13:35 #172705

Não funcionou...
Os icones que aparecem cortados não sao os dos postos , bombeiros etc.... e sim ... os icones Hospital
cameras, parecem que estao sobrepostos. Quando eu retirei do speedcam ele desaparecem mas ou coloca-los de novo volta , como ja disse parecem sobrepostos.
Mas desde ja agradeço a primeira diga, mas nao deu certo
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 15:52 #172722

walmirpinto

Pode ser problema da skin

tente usar o zozo deste link

www.gpspoint.com.br/...n-zozo-com-novidades
  • jps10
  • Usuário Gold
  • jps10's Avatar
  • OFFLINE
  • Postagens: 197
  • Agradecimentos: 18
  • Registro em: 02/04/2012
    Ult. Visita: 09/03/2013
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 18:26 #172734

troquei e nao funcionou... esse problema esta acontecendo com qualquer skin... nao sei mais o que fazer
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 18:35 #172736

Estão aparecendo dois ícones no mesmo local? (um sobrepondo o outro)
  • Fábio M.
  • Moderador
  • Fábio M.'s Avatar
  • OFFLINE
  • Postagens: 3372
  • Agradecimentos: 1247
  • Registro em: 20/10/2011
    Ult. Visita: 09/12/2016
Pesquise sempre! O fórum tem um acervo enorme com dúvidas respondidas. Evite abrir novos tópicos, utilize os tópicos já existentes.
Não crie uma nova mensagem para agradecer, clique apenas em 'Agradecimento' se a resposta lhe foi útil.
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 19:10 #172741

Sim,,,,
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 19:43 #172749

Walmir

Apague o arquivo speedcam.spdb. Saia do navegador e entre novamente.

Demorará mais para iniciar o navegador pois o arquivo que você apagou estará sendo recriado.

Veja se resolveu e reporte.
  • Fábio M.
  • Moderador
  • Fábio M.'s Avatar
  • OFFLINE
  • Postagens: 3372
  • Agradecimentos: 1247
  • Registro em: 20/10/2011
    Ult. Visita: 09/12/2016
Pesquise sempre! O fórum tem um acervo enorme com dúvidas respondidas. Evite abrir novos tópicos, utilize os tópicos já existentes.
Não crie uma nova mensagem para agradecer, clique apenas em 'Agradecimento' se a resposta lhe foi útil.
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 21:04 #172766

Fabio.... ja fiz de tudo.. ...
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 21:08 #172768

Você deve estar deixando passar algum detalhe...
  • Fábio M.
  • Moderador
  • Fábio M.'s Avatar
  • OFFLINE
  • Postagens: 3372
  • Agradecimentos: 1247
  • Registro em: 20/10/2011
    Ult. Visita: 09/12/2016
Pesquise sempre! O fórum tem um acervo enorme com dúvidas respondidas. Evite abrir novos tópicos, utilize os tópicos já existentes.
Não crie uma nova mensagem para agradecer, clique apenas em 'Agradecimento' se a resposta lhe foi útil.
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 21:13 #172769

Fiz como foi mandado...... apaguei somente o arquivo solicitado .... como faço para retirar as placas amarelas
Ja troquei tudo que me foi solicitado...
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
Última Edição: 18 Set 2012 21:22 por Fábio M.. Razão: Correção do post
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 21:18 #172770

walmirpinto

Vc consegue tirar uma foto e disponibilizar aqui pra gente ver com mais clareza?
Os ícones estão sobrepostos ou está "metade de um em cima e metade de outra em baixo"?

Esse problema sempre existiu ou aconteceu alguma modificação/atualização que fez no seu aparelho?
  • plot_aqa
  • Gerente
  • Evite Mensagens Privadas para dúvidas. Pesquise!
  • plot_aqa's Avatar
  • OFFLINE
  • Postagens: 7801
  • Agradecimentos: 4072
  • Registro em: 02/08/2010
    Ult. Visita: 23/04/2015
CLIQUE AQUI e Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar !

POR FAVOR, DÚVIDAS APENAS NO FORUM!!!

NÃO EXISTE ATENDIMENTO V.I.P., PORTANTO NÃO ENVIEM MP COM DÚVIDAS TÉCNICAS
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 21:32 #172773

Foto0171.jpg



To anexando a foto.... Nao fiz nada... desde o inicio que apresenta esse problema... pela foto que retirei acho que outros ja tiveram esse problema... ja troquei todos os skin e nada muda..
Valeu
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
Última Edição: 18 Set 2012 21:47 por walmirpinto. Razão: Foto
O administrador desabilitou o acesso público de escrita.

Re: IgoPrimo 2.0 - skin 18 Set 2012 22:10 #172779

Bom, como eu suspeitava, trata-se do "metade de um em cima e metade do outro em baixo". Não sei o pq disso acontecer, já que imaginava que o navegador estivesse 100% testado.

O problema está no DATA.ZIP, e por isso qualquer skin (que não defina seus próprios ícones de speedwarn) terá o mesmo comportamento. Não tenho como te ajudar sem ter os arquivos em mãos, mesmo pq não uso o Primo.

Vou explicar o que acontece e talvez algum colega possa fazer as correções. Existe um arquivo chamado SPEEDWARN.BMP onde estão todos os ícones de radares e alertas, "um em cima do outro". Cada ícone possui um certo número de pixels na vertical (por exemplo, 40). O arquivo, então, terá na vertical um total de pixels que será 40 vezes o número total de ícones. Existe um arquivo chamado SPEEDWARN.SPR, que diz quantos pixels cada ícone possui (deve ser 40, nesse exemplo). Supondo que o navegador tenha que mostra na tela o ícone de número 16, ele vai no SPEEDWARN.BMP e busca os pixels que vão do 601 (=40 X 15 + 1) até o 640 (=40 X 15 +40).

Se o valor dentro do SPR estiver errado (por exemplo, 42 ao invés de 40), ele vai buscar os pixels de 631 (= 42 X 15 + 1) até o 670. Veja que nesse caso, ele está mostrando na tela partes de dois ícones distintos. Quanto mais "longe" o ícone está do começo do arquivo, mais "misturado" estará o que aparece na tela. Por outro lado, os ícones do começo do arquivo quase que não sofrem alterações. Não por coincidência, os primeiros ícones são os de radares e os últimos os de alertas. Por isso que os radares aparecem "normais" na sua tela.

Outro ponto que pode estar errado é que os ícones dentro do SPEEDWARN.BMP não possuem o mesmo número de pixels. Se um possui 40, outro 37, outro 45, etc, o modo de busca do ícone certo tb vai terminar em problemas....

É técnico, mas creio que deu pra entender a coisa.... só não tenho como corrigir.

É isso.
  • plot_aqa
  • Gerente
  • Evite Mensagens Privadas para dúvidas. Pesquise!
  • plot_aqa's Avatar
  • OFFLINE
  • Postagens: 7801
  • Agradecimentos: 4072
  • Registro em: 02/08/2010
    Ult. Visita: 23/04/2015
CLIQUE AQUI e Faça uma doação de qualquer valor e ajude a manter o GPSPoint no ar !

POR FAVOR, DÚVIDAS APENAS NO FORUM!!!

NÃO EXISTE ATENDIMENTO V.I.P., PORTANTO NÃO ENVIEM MP COM DÚVIDAS TÉCNICAS
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: Fábio M.

Re: IgoPrimo 2.0 - skin 18 Set 2012 22:14 #172781

Plot, o Walmir já havia recebido ajuda no tópico do iGO Primo Studio aqui:

www.gpspoint.com.br/...20&start=1660#172695

(sua explicação foi mais elucidativa :oks )
  • Fábio M.
  • Moderador
  • Fábio M.'s Avatar
  • OFFLINE
  • Postagens: 3372
  • Agradecimentos: 1247
  • Registro em: 20/10/2011
    Ult. Visita: 09/12/2016
Pesquise sempre! O fórum tem um acervo enorme com dúvidas respondidas. Evite abrir novos tópicos, utilize os tópicos já existentes.
Não crie uma nova mensagem para agradecer, clique apenas em 'Agradecimento' se a resposta lhe foi útil.
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: plot_aqa

Re: IgoPrimo 2.0 - skin 18 Set 2012 22:41 #172786

Isso ai, o problema eh a resolução do .spr que ele está usando não bate com a resolução do .bmp.
Ai acontece de ficar pela metade ou apenas partes dos arquivos.
  • shdw
  • Colaborador
  • shdw's Avatar
  • OFFLINE
  • Postagens: 635
  • Agradecimentos: 243
  • Registro em: 14/09/2010
    Ult. Visita: 05/12/2016
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: walmirpinto

Re: IgoPrimo 2.0 - skin 18 Set 2012 22:49 #172790

Beleza deu certo... valeu mesmo..
Grato =
  • walmirpinto
  • Iniciante
  • walmirpinto's Avatar
  • OFFLINE
  • Postagens: 16
  • Agradecimentos: 1
  • Registro em: 16/09/2012
    Ult. Visita: 26/09/2016
O administrador desabilitou o acesso público de escrita.

IgoPrimo 2.0 - skin 16 Jan 2014 07:39 #212645

Meus caros...

Vendo a resposta do nosso mestre Plot acima:

Clique aqui! [ Click to expand ]


Gostaria de saber se alguém sabe me explicar onde ficam as configurações (no PRIMO) para determinar qual destes ícones serão usados para um determinado alerta.

Exemplo, para RADAR FIXO, ele busca o ícone que está entre os Pixels 601 e 640 (pegando um gancho no mesmo exemplo do Plot), se for RADAR MÓVEL, vai buscar do 641 ao 680, se CÂMERA NO SEMÁFORO, do 681 ao 720 e assim vai....

Estou com um problema numa Skin que estou modificando que ele está me mostrando na tela o mesmo ícone para 2 tipos de alerta diferentes, e creio que pode ser algo relacionado a isto.

Certo da atenção de vcs, desde já agradeço.

Gde abç,
Cozzi.
  • cozzi
  • Colaborador
  • cozzi's Avatar
  • OFFLINE
  • Postagens: 3060
  • Agradecimentos: 3433
  • Registro em: 01/09/2010
    Ult. Visita: 07/12/2016
Att,
Cozzi (BH/MG) :oks
APONTADOR T500
MIDI JAPAN
FOSTON FS-3D710DT
X3 WF-95
O administrador desabilitou o acesso público de escrita.

IgoPrimo 2.0 - skin 16 Jan 2014 15:49 #212716

Senhores,

Vou tentar colocar um pouco de luz neste assunto que, verão, depois de entendido, é na verdade muito fácil.

Existem, dentro das skins e, em cada resolução, dois arquivos que trabalham juntos:

speedwarn.bmp
speedwarn.spr

Além destes podemos ter também o speedwan0, 1, 2, etc... que são usados por perfis diferentes dentro do iGO.

O bmp, lógico, é o arquivo gráfico que contem todos os tipos de alerta, começando na parte superior, pelo type=0 e na parte inferior fica o type=31.

O .spr é um arquivo de controle e pode ser visualizado e/ou editado com o bloco de notas.

Vou colocar aqui um exemplo real do spr:
BmpFlags = 0
DefFlags = ALPHA_PIXEL | GRAB_BOTTOM | GRAB_HCENTER
DefPhase = 0
Stripes = 82

A única coisa que podemos alterar é o valor na linha Stripes. O que quer dizer o valor 82 do exemplo?

Lembram que eu disse que a "tripa gráfica" tem os ícones de 0 a 31? Ou seja 32 posições?

Então se o valor é 82, multiplicamos 82 * 32 e encontramos o valor de 2624. Este será o valor da altura, em pixels, do nosso speedwarn.bmp.

Com isto o iGO Primo consegue "pegar" a figura exata do alerta indexada pelo seu "type".

Obs: Isto é verdade para o Primo, iGO8 ou Amigo não sei.
O speedwarn1 é o normalmente usado pois, por padrão é o perfil 1 o usado.

Espero ter colocado um pouco de luz no assunto.
  • adinis
  • Usuário Platinum
  • adinis's Avatar
  • OFFLINE
  • Postagens: 1001
  • Agradecimentos: 1218
  • Registro em: 29/10/2011
    Ult. Visita: 21/11/2016
Numa civilização ideal todos deveríamos ter os mesmos privilégios e regras mas, sabemos, que no dia a dia isto não é assim. Por isto "utopia" passou a ser sinônimo de desejável mas não alcançável. Pena!
O administrador desabilitou o acesso público de escrita.
Os seguintes usuários disseram Obrigado: cozzi

IgoPrimo 2.0 - skin 16 Jan 2014 19:18 #212737

Grande adinis,

Excelente aula...sério mesmo... :oks

Eu entendi perfeitamente, mas só faltou uma coisinha:
Com isto o iGO Primo consegue "pegar" a figura exata do alerta indexada pelo seu "type".

A minha pergunta principal era exatamente "aonde fica configuração"? Ou seja, qual arquivo no PRIMO me diz: para o TYPE "X" ler a figura que está no PIXEL tal do arquivo speedwarn1.bmp por exemplo?

Entendeu? ...rs

Muito obrigado mesmo.

abçs.
  • cozzi
  • Colaborador
  • cozzi's Avatar
  • OFFLINE
  • Postagens: 3060
  • Agradecimentos: 3433
  • Registro em: 01/09/2010
    Ult. Visita: 07/12/2016
Att,
Cozzi (BH/MG) :oks
APONTADOR T500
MIDI JAPAN
FOSTON FS-3D710DT
X3 WF-95
O administrador desabilitou o acesso público de escrita.
  • Página:
  • 1
Time to create page: 0.343 seconds